<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">

<title>This week in KDE: UI improvements abound &#8211; Adventures in Linux and KDE</title>
<meta name='robots' content='max-image-preview:large' />

<!-- Async WordPress.com Remote Login -->
<script id="wpcom_remote_login_js">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</script>
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//pointieststick.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//wordpress.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Adventures in Linux and KDE &raquo; Feed" href="https://pointieststick.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Adventures in Linux and KDE &raquo; Comments Feed" href="https://pointieststick.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Adventures in Linux and KDE &raquo; This week in KDE: UI improvements&nbsp;abound Comments Feed" href="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
	<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1652185836h&ver=6.1-alpha-54228"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link crossorigin='anonymous' rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJytkkluAyEQRS8UwG0nrWyinIWhRMpmEgW2uL3pztRpO3YW2SB9qt5XTeKUmI6hQCjCV5ZctRhInJKOnpFHB22luCZ6ENexDE4WMCxFKit1C3N4ABJ7KEnqA5vVRfpnrq1dKsi2RzKI4/DId3wQqqIzQrk4G6gscxNUmoP/MCpv4L+NMGhXzVQwCQ8GJbgenjpaiORkg8wcWKkb9xju4z221D+g34ufK10MT7ZYC7MZzZ/7X1lkWTBYuoPr+IFt+fDMB0bokwOW4ch3wiCVrwx23Wix/2kB/d8neTmFG9j7WSqVMhCx/nqsns3Lmu/n1b8M4zhuN0/jZtyfAbTjFv0=?cssminify=yes' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify {
	text-align:justify;
}
.wp-block-cover__image-background.has-parallax {
	background-size: cover;
}
</style>
<style id='global-styles-inline-css'>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</style>
<link crossorigin='anonymous' rel='stylesheet' id='all-css-2-1' href='https://s0.wp.com/_static/??-eJydUF1PwzAM/EOkXgfkDfFTUJOazFu+FCer9u9xWwEVTHvoS3Tn6M6+gykrm2LFWCH75igyuCbUYHHyUxCu/Uv33PVgGvkRjE/2ojyZMpQbWD8wk+0s8xNsrEJT3242hSAjkVxQGP+ZrFKCmCqJmn/AI88z1jzIGSuHXNLYbKUU4YOiBYcRy+p2F/6zricMclxuBiiOmFEeOVC4Jz5hUUfgevO4RzgnXkrbtXaOs6xWU5be9pUSBHlZNNHosDLUlFVOLOh+qo2pw6Tk+GHx2RL16Qcqj6QFJbYT6JYOfukseg9vvdb6eHjVB33+Aio88w8=?cssminify=yes' type='text/css' media='all' />
<link crossorigin='anonymous' rel='stylesheet' id='print-css-3-1' href='https://s2.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h&cssminify=yes' type='text/css' media='print' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<link crossorigin='anonymous' rel='stylesheet' id='all-css-6-1' href='https://s0.wp.com/_static/??-eJyVjUEKwjAQRS9kHCo10IV4FImTkKROZkInQby9bXEjrty9B5/34VkNCrfADUo3lXrMrDCHVh0+Pg51Ed+xZWEoK1FQ0OSW4J33rx0zxyOqHuDf3i0zggpmR4Ykin7JT7OlUNb3NEIkuTvaBtdyGezZjqdpssP8Bj+XTks=?cssminify=yes' type='text/css' media='all' />
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script id='wpcom-actionbar-placeholder-js-extra'>
var actionbardata = {"siteID":"140354881","siteURL":"https:\/\/pointieststick.com","xhrURL":"https:\/\/pointieststick.com\/wp-admin\/admin-ajax.php","nonce":"01afb12136","isLoggedIn":"","statusMessage":"","subsEmailDefault":"instantly","proxyScriptUrl":"https:\/\/s0.wp.com\/wp-content\/js\/wpcom-proxy-request.js?ver=20211021","shortlink":"https:\/\/wp.me\/p9uUIp-3sT","i18n":{"followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/read\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar"}};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/_static/??/wp-content/js/mobile-useragent-info.js,/wp-content/mu-plugins/related-posts/related-posts.js,/wp-content/js/rlt-proxy.js?m=1637704497j'></script>
<script type='text/javascript'>
	window.addEventListener( 'DOMContentLoaded', function() {
		rltInitialize( {"token":null,"iframeOrigins":["https:\/\/widgets.wp.com"]} );
	} );
</script>
<link crossorigin='anonymous' rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1663315160h&cssminify=yes' type='text/css' media='all' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://pointieststick.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/" />
<link rel='shortlink' href='https://wp.me/p9uUIp-3sT' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fpointieststick.com%2F2022%2F10%2F21%2Fthis-week-in-kde-ui-improvements-abound-2%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fpointieststick.com%2F2022%2F10%2F21%2Fthis-week-in-kde-ui-improvements-abound-2%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="This week in KDE: UI improvements abound" />
<meta property="og:url" content="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/" />
<meta property="og:description" content="A ton of UI improvements landed this week. If you can&#8217;t find something to like in this post, I&#8217;ll eat my hat! New Features System Settings&#8217; Firewall page now supports IP address s…" />
<meta property="article:published_time" content="2022-10-22T04:42:09+00:00" />
<meta property="article:modified_time" content="2022-10-22T04:42:09+00:00" />
<meta property="og:site_name" content="Adventures in Linux and KDE" />
<meta property="og:image" content="https://pointieststick.files.wordpress.com/2022/10/image-9.png" />
<meta property="og:image:width" content="3588" />
<meta property="og:image:height" content="1906" />
<meta property="og:image:alt" content="" />
<meta property="og:locale" content="en_US" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<meta name="twitter:text:title" content="This week in KDE: UI improvements&nbsp;abound" />
<meta name="twitter:image" content="https://pointieststick.files.wordpress.com/2022/10/image-9.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon" href="https://s2.wp.com/i/webclip.png" />
<link rel="search" type="application/opensearchdescription+xml" href="https://pointieststick.com/osd.xml" title="Adventures in Linux and KDE" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="application-name" content="Adventures in Linux and KDE" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Below is a brief look at recent changes in the KDE projects I work on and follow!" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://pointieststick.com/feed/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="A ton of UI improvements landed this week. If you can&#039;t find something to like in this post, I&#039;ll eat my hat! New Features System Settings&#039; Firewall page now supports IP address strings with netmasks (Daniel Vrátil, Plasma 5.27. Link) User Interface Improvements On the Information tab of Gwenview&#039;s sidebar, you can now reduce the&hellip;" />
</head>

<body class="post-template-default single single-post postid-13323 single-format-standard wp-embed-responsive customizer-styles-applied has-sidebar highlander-enabled highlander-light">

<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<div id="hero-header" class="site-hero-section">
		<header id="masthead" class="site-header" role="banner">
			<div class="inner">
				<div class="site-branding">
					
											<a class="site-logo-link" href="https://pointieststick.com/">
							<img alt="" class="site-logo-image no-grav" width="80" height="80" src="https://secure.gravatar.com/avatar/2c6c3c992e1122273dc3d92970d68781?s=160&#038;d=blank&#038;r=g" />
						</a><!-- .site-logo-link -->
													<p class="site-title"><a href="https://pointieststick.com/" rel="home">Adventures in Linux and KDE</a></p>
													<p class="site-description">Below is a brief look at recent changes in the KDE projects I work on and follow!</p>
									</div><!-- .site-branding -->

				
									<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false" id="primary-menu-button">
						Menu					</button><!-- .menu-toggle -->
				
			</div><!-- .inner -->
		</header><!-- #masthead -->
	</div>

				<nav id="site-navigation" class="main-navigation" role="navigation">
			<div class="menu-primary-container"><ul id="primary-menu" class="menu"><li id="menu-item-1508" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1508"><a href="https://community.kde.org/Get_Involved">Get involved</a></li>
<li id="menu-item-1506" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1506"><a href="https://community.kde.org/Get_Involved/Bug_Reporting">Report a bug</a></li>
<li id="menu-item-1505" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1505"><a href="https://community.kde.org/Get_Involved/development">Develop for KDE</a></li>
<li id="menu-item-1507" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1507"><a href="https://community.kde.org/Infrastructure/GitLab">Submit a patch</a></li>
<li id="menu-item-10" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10"><a href="https://pointieststick.com/contact/">Contact me</a></li>
</ul></div>		</nav><!-- .main-navigation -->
	
	
	
	<div id="content-wrapper" class="content-wrapper">
		<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-13323" class="post-13323 post type-post status-publish format-standard hentry category-this-week-in-kde">
			<header class="entry-header">
			<h1 class="entry-title">This week in KDE: UI improvements&nbsp;abound</h1>		</header><!-- .entry-header -->		<div class="entry-meta">
			<span class="byline">
				<a href="https://pointieststick.com/author/pointieststick/" title="Posts by Nate" rel="author">Nate</a>			</span>
							<span class="cat-links">
					<a href="https://pointieststick.com/category/this-week-in-kde/" rel="category tag">This Week in KDE</a>				</span><!-- .cat-links -->
			
			
			<span class="published-on">
				<time class="entry-date published updated" datetime="2022-10-21T22:42:09-06:00">October 21, 2022</time>			</span>

			<span class="word-count">4 Minutes</span>		</div><!-- .entry-meta -->
	
	<div class="entry-content">
		
<p>A ton of UI improvements landed this week. If you can&#8217;t find something to like in this post, I&#8217;ll eat my hat!</p>



<h2 id="new-features">New Features</h2>



<p>System Settings&#8217; Firewall page now supports IP address strings with netmasks (Daniel Vrátil, Plasma 5.27. <a href="https://bugs.kde.org/show_bug.cgi?id=434317">Link</a>)</p>



<h2 id="user-interface-improvements">User Interface Improvements</h2>



<p>On the Information tab of Gwenview&#8217;s sidebar, you can now reduce the area taken up by the metadata and description section using a draggable splitter between it and the Image Information section that&#8217;s above it. The splitter remembers its position, too! (Corbin Schwimmbeck, Gwenview 22.12. <a href="https://bugs.kde.org/show_bug.cgi?id=332921">Link</a>)</p>


<div class="wp-block-image">
<figure class="aligncenter size-full is-resized"><img loading="lazy" data-attachment-id="13447" data-permalink="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/image-7/" data-orig-file="https://pointieststick.files.wordpress.com/2022/10/image-7.png" data-orig-size="2134,1896" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="image-7" data-image-description="" data-image-caption="" data-medium-file="https://pointieststick.files.wordpress.com/2022/10/image-7.png?w=300" data-large-file="https://pointieststick.files.wordpress.com/2022/10/image-7.png?w=1024" src="https://pointieststick.files.wordpress.com/2022/10/image-7.png" alt="" class="wp-image-13447" width="769" height="683" srcset="https://pointieststick.files.wordpress.com/2022/10/image-7.png?w=769&amp;h=683 769w, https://pointieststick.files.wordpress.com/2022/10/image-7.png?w=1538&amp;h=1366 1538w, https://pointieststick.files.wordpress.com/2022/10/image-7.png?w=150&amp;h=133 150w, https://pointieststick.files.wordpress.com/2022/10/image-7.png?w=300&amp;h=267 300w, https://pointieststick.files.wordpress.com/2022/10/image-7.png?w=1024&amp;h=910 1024w" sizes="(max-width: 769px) 100vw, 769px" /></figure></div>


<p>Spectacle now remembers the last-chosen rectangular region area by default, even across app launches. This is configurable, of course (Bharadwaj Raju, Spectacle 22.12. <a href="https://invent.kde.org/graphics/spectacle/-/merge_requests/156">Link</a>)</p>



<p>Kate and KWrite&#8217;s welcome screen (which remains optional, and able to be permanently disabled using a checkbox right on the screen itself) now includes links to documentation (Eugene Popov, Kate and KWrite 22.12. <a href="https://invent.kde.org/utilities/kate/-/merge_requests/957">Link</a>):</p>


<div class="wp-block-image">
<figure class="aligncenter size-full is-resized"><img loading="lazy" data-attachment-id="13445" data-permalink="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/image-6/" data-orig-file="https://pointieststick.files.wordpress.com/2022/10/image-6.png" data-orig-size="1841,1663" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="image-6" data-image-description="" data-image-caption="" data-medium-file="https://pointieststick.files.wordpress.com/2022/10/image-6.png?w=300" data-large-file="https://pointieststick.files.wordpress.com/2022/10/image-6.png?w=1024" src="https://pointieststick.files.wordpress.com/2022/10/image-6.png" alt="" class="wp-image-13445" width="666" height="601" srcset="https://pointieststick.files.wordpress.com/2022/10/image-6.png?w=666&amp;h=601 666w, https://pointieststick.files.wordpress.com/2022/10/image-6.png?w=1332&amp;h=1202 1332w, https://pointieststick.files.wordpress.com/2022/10/image-6.png?w=150&amp;h=135 150w, https://pointieststick.files.wordpress.com/2022/10/image-6.png?w=300&amp;h=271 300w, https://pointieststick.files.wordpress.com/2022/10/image-6.png?w=768&amp;h=694 768w, https://pointieststick.files.wordpress.com/2022/10/image-6.png?w=1024&amp;h=925 1024w" sizes="(max-width: 666px) 100vw, 666px" /></figure></div>


<p>In the Plasma Wayland session, opening Dolphin from the Disks &amp; Devices popup now raises its existing window, if it was already open (Nicolas Fella, Dolphin 22.12 with Plasma 5.26.1. <a href="https://bugs.kde.org/show_bug.cgi?id=460268">Link</a>)</p>



<p>Dragging-and-dropping windows onto the Pager Widget now works a lot better, with less fiddliness (Niccolò Venerandi, Plasma 5.26.1. <a href="https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/1211">Link</a>)</p>



<p>When using Plasma, the &#8220;Open file with app…&#8221; dialog now uses the XDG portal version for improved visual consistency and user-friendliness. The old dialog is still used when you invoke &#8220;Open this file in a different app&#8221; functionality from a KDE app that&#8217;s not being used in Plasma (Harald Sitter, Plasma 5.27. <a href="https://invent.kde.org/plasma/plasma-integration/-/merge_requests/47">Link</a>):</p>


<div class="wp-block-image">
<figure class="aligncenter size-full is-resized"><img loading="lazy" data-attachment-id="13443" data-permalink="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/image-5/" data-orig-file="https://pointieststick.files.wordpress.com/2022/10/image-5.png" data-orig-size="1712,1601" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="image-5" data-image-description="" data-image-caption="" data-medium-file="https://pointieststick.files.wordpress.com/2022/10/image-5.png?w=300" data-large-file="https://pointieststick.files.wordpress.com/2022/10/image-5.png?w=1024" src="https://pointieststick.files.wordpress.com/2022/10/image-5.png" alt="" class="wp-image-13443" width="658" height="616" srcset="https://pointieststick.files.wordpress.com/2022/10/image-5.png?w=658&amp;h=616 658w, https://pointieststick.files.wordpress.com/2022/10/image-5.png?w=1316&amp;h=1232 1316w, https://pointieststick.files.wordpress.com/2022/10/image-5.png?w=150&amp;h=140 150w, https://pointieststick.files.wordpress.com/2022/10/image-5.png?w=300&amp;h=281 300w, https://pointieststick.files.wordpress.com/2022/10/image-5.png?w=768&amp;h=718 768w, https://pointieststick.files.wordpress.com/2022/10/image-5.png?w=1024&amp;h=958 1024w" sizes="(max-width: 658px) 100vw, 658px" /></figure></div>


<p>System Tray Widgets that can be middle-clicked to toggle something about them on or off now indicate as such in their tooltips (me: Nate Graham, Plasma 5.27. <a href="https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/2205">Link 1</a>, <a href="https://invent.kde.org/plasma/bluedevil/-/merge_requests/101">link 2</a>, and <a href="https://invent.kde.org/plasma/plasma-pa/-/merge_requests/143">link 3</a>):</p>



<div class="wp-block-jetpack-slideshow aligncenter" data-effect="slide"><div class="wp-block-jetpack-slideshow_container swiper-container"><ul class="wp-block-jetpack-slideshow_swiper-wrapper swiper-wrapper"><li class="wp-block-jetpack-slideshow_slide swiper-slide"><figure><img alt="" class="wp-block-jetpack-slideshow_image wp-image-13325" data-id="13325" src="https://pointieststick.files.wordpress.com/2022/10/middle-click_to_mute.png?w=820" srcset="https://pointieststick.files.wordpress.com/2022/10/middle-click_to_mute.png 820w, https://pointieststick.files.wordpress.com/2022/10/middle-click_to_mute.png?w=150 150w, https://pointieststick.files.wordpress.com/2022/10/middle-click_to_mute.png?w=300 300w, https://pointieststick.files.wordpress.com/2022/10/middle-click_to_mute.png?w=768 768w" sizes="(max-width: 820px) 100vw, 820px" /></figure></li><li class="wp-block-jetpack-slideshow_slide swiper-slide"><figure><img alt="" class="wp-block-jetpack-slideshow_image wp-image-13326" data-id="13326" src="https://pointieststick.files.wordpress.com/2022/10/middle_click_to_enable_bluetooth.jpg?w=1024" srcset="https://pointieststick.files.wordpress.com/2022/10/middle_click_to_enable_bluetooth.jpg?w=1024 1024w, https://pointieststick.files.wordpress.com/2022/10/middle_click_to_enable_bluetooth.jpg?w=150 150w, https://pointieststick.files.wordpress.com/2022/10/middle_click_to_enable_bluetooth.jpg?w=300 300w, https://pointieststick.files.wordpress.com/2022/10/middle_click_to_enable_bluetooth.jpg?w=768 768w, https://pointieststick.files.wordpress.com/2022/10/middle_click_to_enable_bluetooth.jpg 1182w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure></li><li class="wp-block-jetpack-slideshow_slide swiper-slide"><figure><img alt="" class="wp-block-jetpack-slideshow_image wp-image-13327" data-id="13327" src="https://pointieststick.files.wordpress.com/2022/10/middle-click_to_exit_dnd_mode.jpg?w=948" srcset="https://pointieststick.files.wordpress.com/2022/10/middle-click_to_exit_dnd_mode.jpg 948w, https://pointieststick.files.wordpress.com/2022/10/middle-click_to_exit_dnd_mode.jpg?w=150 150w, https://pointieststick.files.wordpress.com/2022/10/middle-click_to_exit_dnd_mode.jpg?w=300 300w, https://pointieststick.files.wordpress.com/2022/10/middle-click_to_exit_dnd_mode.jpg?w=768 768w" sizes="(max-width: 948px) 100vw, 948px" /></figure></li><li class="wp-block-jetpack-slideshow_slide swiper-slide"><figure><img alt="" class="wp-block-jetpack-slideshow_image wp-image-13328" data-id="13328" src="https://pointieststick.files.wordpress.com/2022/10/middle-click_to_play_media_player.jpg?w=1024" srcset="https://pointieststick.files.wordpress.com/2022/10/middle-click_to_play_media_player.jpg?w=1024 1024w, https://pointieststick.files.wordpress.com/2022/10/middle-click_to_play_media_player.jpg?w=150 150w, https://pointieststick.files.wordpress.com/2022/10/middle-click_to_play_media_player.jpg?w=300 300w, https://pointieststick.files.wordpress.com/2022/10/middle-click_to_play_media_player.jpg?w=768 768w, https://pointieststick.files.wordpress.com/2022/10/middle-click_to_play_media_player.jpg 1158w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure></li></ul><a class="wp-block-jetpack-slideshow_button-prev swiper-button-prev swiper-button-white" role="button"></a><a class="wp-block-jetpack-slideshow_button-next swiper-button-next swiper-button-white" role="button"></a><a aria-label="Pause Slideshow" class="wp-block-jetpack-slideshow_button-pause" role="button"></a><div class="wp-block-jetpack-slideshow_pagination swiper-pagination swiper-pagination-white"></div></div></div>



<p>In the Plasma Wayland session, Help Center is now able to raise its open window when activated by another app (Nicolas Fella, Help Center 5.27. <a href="https://invent.kde.org/system/khelpcenter/-/merge_requests/21">Link</a>)</p>



<p>The icon size popup in System Settings has gotten a UI overhaul to remove unused settings and make what it does do more comprehensible (me: Nate Graham, Plasma 5.27. <a href="https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/2214">Link</a>):</p>


<div class="wp-block-image">
<figure class="aligncenter size-full is-resized"><img loading="lazy" data-attachment-id="13423" data-permalink="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/icons-popup/" data-orig-file="https://pointieststick.files.wordpress.com/2022/10/icons-popup.png" data-orig-size="2442,1784" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="icons-popup" data-image-description="" data-image-caption="" data-medium-file="https://pointieststick.files.wordpress.com/2022/10/icons-popup.png?w=300" data-large-file="https://pointieststick.files.wordpress.com/2022/10/icons-popup.png?w=1024" src="https://pointieststick.files.wordpress.com/2022/10/icons-popup.png" alt="" class="wp-image-13423" width="764" height="558" srcset="https://pointieststick.files.wordpress.com/2022/10/icons-popup.png?w=764&amp;h=558 764w, https://pointieststick.files.wordpress.com/2022/10/icons-popup.png?w=1528&amp;h=1116 1528w, https://pointieststick.files.wordpress.com/2022/10/icons-popup.png?w=150&amp;h=110 150w, https://pointieststick.files.wordpress.com/2022/10/icons-popup.png?w=300&amp;h=219 300w, https://pointieststick.files.wordpress.com/2022/10/icons-popup.png?w=768&amp;h=561 768w, https://pointieststick.files.wordpress.com/2022/10/icons-popup.png?w=1024&amp;h=748 1024w" sizes="(max-width: 764px) 100vw, 764px" /></figure></div>


<p>When you resize the Plasma calendar popup, text in the calendar itself now scales up and down appropriately (Fushan Wen, Plasma 5.27. <a href="https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/2204">Link</a>):</p>


<div class="wp-block-image">
<figure class="aligncenter size-full is-resized"><img loading="lazy" data-attachment-id="13461" data-permalink="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/image-9/" data-orig-file="https://pointieststick.files.wordpress.com/2022/10/image-9.png" data-orig-size="3588,1906" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="image-9" data-image-description="" data-image-caption="" data-medium-file="https://pointieststick.files.wordpress.com/2022/10/image-9.png?w=300" data-large-file="https://pointieststick.files.wordpress.com/2022/10/image-9.png?w=1024" src="https://pointieststick.files.wordpress.com/2022/10/image-9.png" alt="" class="wp-image-13461" width="753" height="400" srcset="https://pointieststick.files.wordpress.com/2022/10/image-9.png?w=753&amp;h=400 753w, https://pointieststick.files.wordpress.com/2022/10/image-9.png?w=1506&amp;h=800 1506w, https://pointieststick.files.wordpress.com/2022/10/image-9.png?w=150&amp;h=80 150w, https://pointieststick.files.wordpress.com/2022/10/image-9.png?w=300&amp;h=159 300w, https://pointieststick.files.wordpress.com/2022/10/image-9.png?w=768&amp;h=408 768w, https://pointieststick.files.wordpress.com/2022/10/image-9.png?w=1024&amp;h=544 1024w" sizes="(max-width: 753px) 100vw, 753px" /></figure></div>


<p>The Overview, Present Windows, and Desktop Grid effects now try harder to pack windows efficiently, so hopefully you won&#8217;t see windows arranged like staircases anymore (Vlad Zahorodnii, Plasma 5.27. <a href="https://invent.kde.org/plasma/kwin/-/merge_requests/3054">Link</a>)</p>



<p>When viewing the page for a Flatpak app that has been marked as &#8220;end-of-life&#8221; by its developer, Discover now shows you the reason given by the developer (Aleix Pol Gonzalez, Plasma 5.27. <a href="https://invent.kde.org/plasma/discover/-/merge_requests/378">Link</a>)</p>



<p>Shadows behind the clock and date text on the login and lock screens are now a bit softer and prettier (Bharadwaj Raju, Plasma 5.27. <a href="https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/2196">Link</a>):</p>


<div class="wp-block-image">
<figure class="aligncenter size-full is-resized"><img loading="lazy" data-attachment-id="13330" data-permalink="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/nicer-lockscreen-shadows/" data-orig-file="https://pointieststick.files.wordpress.com/2022/10/nicer-lockscreen-shadows.png" data-orig-size="515,209" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="nicer-lockscreen-shadows" data-image-description="" data-image-caption="" data-medium-file="https://pointieststick.files.wordpress.com/2022/10/nicer-lockscreen-shadows.png?w=300" data-large-file="https://pointieststick.files.wordpress.com/2022/10/nicer-lockscreen-shadows.png?w=515" src="https://pointieststick.files.wordpress.com/2022/10/nicer-lockscreen-shadows.png" alt="" class="wp-image-13330" width="386" height="157" srcset="https://pointieststick.files.wordpress.com/2022/10/nicer-lockscreen-shadows.png?w=386&amp;h=157 386w, https://pointieststick.files.wordpress.com/2022/10/nicer-lockscreen-shadows.png?w=150&amp;h=61 150w, https://pointieststick.files.wordpress.com/2022/10/nicer-lockscreen-shadows.png?w=300&amp;h=122 300w, https://pointieststick.files.wordpress.com/2022/10/nicer-lockscreen-shadows.png 515w" sizes="(max-width: 386px) 100vw, 386px" /></figure></div>


<p>The Lock Keys Widget now shows a different icon from the Keyboard Layout Widget, so can distinguish between them at a glance (Bharadwaj Raju, Plasma 5.27. <a href="https://bugs.kde.org/show_bug.cgi?id=460357">Link</a>):</p>


<div class="wp-block-image">
<figure class="aligncenter size-full is-resized"><img loading="lazy" data-attachment-id="13405" data-permalink="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/image-4-2/" data-orig-file="https://pointieststick.files.wordpress.com/2022/10/image-4.png" data-orig-size="380,364" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="image-4" data-image-description="" data-image-caption="" data-medium-file="https://pointieststick.files.wordpress.com/2022/10/image-4.png?w=300" data-large-file="https://pointieststick.files.wordpress.com/2022/10/image-4.png?w=380" src="https://pointieststick.files.wordpress.com/2022/10/image-4.png" alt="" class="wp-image-13405" width="190" height="182" srcset="https://pointieststick.files.wordpress.com/2022/10/image-4.png?w=190&amp;h=182 190w, https://pointieststick.files.wordpress.com/2022/10/image-4.png?w=150&amp;h=144 150w, https://pointieststick.files.wordpress.com/2022/10/image-4.png?w=300&amp;h=287 300w, https://pointieststick.files.wordpress.com/2022/10/image-4.png 380w" sizes="(max-width: 190px) 100vw, 190px" /></figure></div>


<p>In the Plasma Wayland session, the &#8220;Something is recording your screen&#8221; System Tray icon now uses a more correct &#8220;recording&#8221;-style icon (me: Nate Graham, Plasma 5.27. <a href="https://bugs.kde.org/show_bug.cgi?id=460514">Link</a>):</p>


<div class="wp-block-image">
<figure class="aligncenter size-full is-resized"><img loading="lazy" data-attachment-id="13399" data-permalink="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/after-7/" data-orig-file="https://pointieststick.files.wordpress.com/2022/10/after.jpg" data-orig-size="956,488" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="after" data-image-description="" data-image-caption="" data-medium-file="https://pointieststick.files.wordpress.com/2022/10/after.jpg?w=300" data-large-file="https://pointieststick.files.wordpress.com/2022/10/after.jpg?w=956" src="https://pointieststick.files.wordpress.com/2022/10/after.jpg" alt="" class="wp-image-13399" width="478" height="244" srcset="https://pointieststick.files.wordpress.com/2022/10/after.jpg?w=478&amp;h=244 478w, https://pointieststick.files.wordpress.com/2022/10/after.jpg?w=150&amp;h=77 150w, https://pointieststick.files.wordpress.com/2022/10/after.jpg?w=300&amp;h=153 300w, https://pointieststick.files.wordpress.com/2022/10/after.jpg?w=768&amp;h=392 768w, https://pointieststick.files.wordpress.com/2022/10/after.jpg 956w" sizes="(max-width: 478px) 100vw, 478px" /></figure></div>


<p>Trying to trash an item that&#8217;s bigger than the current trash size now gives you the option to delete it immediately if you want (Ahmad Samir, Dolphin 22.12 with Frameworks 5.100. <a href="https://bugs.kde.org/show_bug.cgi?id=431351">Link</a>):</p>


<div class="wp-block-image">
<figure class="aligncenter size-full is-resized"><img loading="lazy" data-attachment-id="13456" data-permalink="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/image-8/" data-orig-file="https://pointieststick.files.wordpress.com/2022/10/image-8.png" data-orig-size="1788,818" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="image-8" data-image-description="" data-image-caption="" data-medium-file="https://pointieststick.files.wordpress.com/2022/10/image-8.png?w=300" data-large-file="https://pointieststick.files.wordpress.com/2022/10/image-8.png?w=1024" src="https://pointieststick.files.wordpress.com/2022/10/image-8.png" alt="" class="wp-image-13456" width="751" height="344" srcset="https://pointieststick.files.wordpress.com/2022/10/image-8.png?w=751&amp;h=344 751w, https://pointieststick.files.wordpress.com/2022/10/image-8.png?w=1502&amp;h=688 1502w, https://pointieststick.files.wordpress.com/2022/10/image-8.png?w=150&amp;h=69 150w, https://pointieststick.files.wordpress.com/2022/10/image-8.png?w=300&amp;h=137 300w, https://pointieststick.files.wordpress.com/2022/10/image-8.png?w=768&amp;h=351 768w, https://pointieststick.files.wordpress.com/2022/10/image-8.png?w=1024&amp;h=468 1024w" sizes="(max-width: 751px) 100vw, 751px" /></figure></div>


<p>Avatar images throughout KDE software are now sharper and better-looking when using a high DPI screen and screen scaling (Fushan Wen, Frameworks 5.100. <a href="https://invent.kde.org/frameworks/kirigami/-/merge_requests/771">Link</a>)</p>



<p>Recent Documents lists throughout KDE software will now display appropriate icons for the recent files (Eric Armbruster, Frameworks 5.100. <a href="https://invent.kde.org/frameworks/kconfigwidgets/-/merge_requests/163">Link</a>)</p>



<h2 id="15-minute-bugs-resolved">Significant Bugfixes</h2>



<p class="has-small-font-size">(This is a curated list of e.g. HI and VHI priority bugs, Wayland showstoppers, major regressions, etc.)</p>



<p>Fixed another cause of desktop widgets slightly moving around on login, which apparently has multiple causes (Aaron Rainbolt, Plasma 5.24.8. <a href="https://bugs.kde.org/show_bug.cgi?id=460618">Link</a>)</p>



<p>Fixed an issue that could cause input to not be detected when using the new mouse button rebinding feature (David Redondo, Plasma 5.26.2 with Frameworks 5.100. <a href="https://bugs.kde.org/show_bug.cgi?id=460345">Link</a>)</p>



<p>Plasma no longer constantly consumes high CPU resources when using an animated AVIF image as your wallpaper (Fushan Wen, Frameworks 5.100. <a href="https://bugs.kde.org/show_bug.cgi?id=460085">Link</a>)</p>



<p>Plasma no longer constantly consumes high CPU resources when disabling middle-click paste and copying certain content (David Edmundson, Frameworks 5.100. <a href="https://bugs.kde.org/show_bug.cgi?id=460248">Link</a>)</p>



<p>Other bug-related information of interest:</p>



<ul>
<li>11 Very high priority Plasma bugs (up from 10 last week). <a href="https://bugs.kde.org/buglist.cgi?bug_severity=critical&amp;bug_severity=grave&amp;bug_severity=major&amp;bug_severity=crash&amp;bug_severity=normal&amp;bug_severity=minor&amp;bug_severity=task&amp;bug_status=UNCONFIRMED&amp;bug_status=CONFIRMED&amp;bug_status=ASSIGNED&amp;bug_status=REOPENED&amp;known_name=VHI-priority%20Plasma%20bugs&amp;list_id=2125490&amp;priority=VHI&amp;product=Bluedevil&amp;product=Breeze&amp;product=Discover&amp;product=drkonqi&amp;product=frameworks-kirigami&amp;product=frameworks-plasma&amp;product=frameworks-qqc2-desktop-style&amp;product=kactivitymanagerd&amp;product=kde-gtk-config&amp;product=kdeplasma-addons&amp;product=khelpcenter&amp;product=kinfocenter&amp;product=klipper&amp;product=kmenuedit&amp;product=krunner&amp;product=KScreen&amp;product=kscreenlocker&amp;product=ksmserver&amp;product=ksysguard&amp;product=KSystemLog&amp;product=kwin&amp;product=Plasma%20SDK&amp;product=Plasma%20Vault&amp;product=Plasma%20Workspace%20Wallpapers&amp;product=plasma-integration&amp;product=plasma-nm&amp;product=plasma-pa&amp;product=plasma-simplemenu&amp;product=plasmashell&amp;product=policykit-kde-agent-1&amp;product=Powerdevil&amp;product=print-manager&amp;product=printer-applet&amp;product=pulseaudio-qt&amp;product=systemsettings&amp;product=Touchpad-KCM&amp;product=user-manager&amp;product=xdg-desktop-portal-kde&amp;query_based_on=VHI-priority%20Plasma%20bugs&amp;query_format=advanced">Current list of bugs</a></li>



<li>55 15-minute Plasma bugs (up from 53 last week). <a href="https://bugs.kde.org/buglist.cgi?bug_severity=critical&amp;bug_severity=grave&amp;bug_severity=major&amp;bug_severity=crash&amp;bug_severity=normal&amp;bug_severity=minor&amp;bug_severity=task&amp;bug_status=UNCONFIRMED&amp;bug_status=CONFIRMED&amp;bug_status=ASSIGNED&amp;bug_status=REOPENED&amp;known_name=VHI-priority%20Plasma%20bugs&amp;list_id=2101429&amp;priority=HI&amp;product=Bluedevil&amp;product=Breeze&amp;product=Discover&amp;product=drkonqi&amp;product=frameworks-plasma&amp;product=kactivitymanagerd&amp;product=kde-gtk-config&amp;product=kdeplasma-addons&amp;product=khelpcenter&amp;product=kinfocenter&amp;product=klipper&amp;product=kmenuedit&amp;product=krunner&amp;product=KScreen&amp;product=kscreenlocker&amp;product=ksmserver&amp;product=ksysguard&amp;product=KSystemLog&amp;product=kwayland-integration&amp;product=kwin&amp;product=Plasma%20SDK&amp;product=Plasma%20Vault&amp;product=Plasma%20Workspace%20Wallpapers&amp;product=plasma-disks&amp;product=plasma-integration&amp;product=plasma-nm&amp;product=plasma-pa&amp;product=plasma-simplemenu&amp;product=plasma-systemmonitor&amp;product=plasmashell&amp;product=policykit-kde-agent-1&amp;product=Powerdevil&amp;product=print-manager&amp;product=printer-applet&amp;product=pulseaudio-qt&amp;product=systemsettings&amp;product=xdg-desktop-portal-kde&amp;query_based_on=VHI-priority%20Plasma%20bugs&amp;query_format=advanced">Current list of bugs</a></li>



<li>144 KDE bugs of all kinds fixed this week. <a href="https://bugs.kde.org/buglist.cgi?bug_severity=critical&amp;bug_severity=grave&amp;bug_severity=major&amp;bug_severity=crash&amp;bug_severity=normal&amp;bug_severity=minor&amp;bug_status=RESOLVED&amp;chfield=bug_status&amp;chfieldfrom=2022-10-14&amp;chfieldto=2022-10-21&amp;chfieldvalue=RESOLVED&amp;list_id=2184176&amp;query_format=advanced&amp;resolution=FIXED">Full list of bugs</a></li>
</ul>



<h2>Automation &amp; Systematization</h2>



<p>This goal now has a Matrix room! Search for <code>kde-institutional-memory:kde.org</code> in your favorite Matrix client, or <a href="https://webchat.kde.org/#/room/#kde-institutional-memory:kde.org">click here</a> to access it in the web client.</p>



<p>The goal also has a team on <a href="https://invent.kde.org" rel="nofollow">https://invent.kde.org</a>! You can join at <a href="https://invent.kde.org/groups/teams/automation/-/group_members" rel="nofollow">https://invent.kde.org/groups/teams/automation/-/group_members</a>. We&#8217;ll be using this for long-term task coordination via the task tracker at <a href="https://invent.kde.org/teams/automation/issues/-/issues" rel="nofollow">https://invent.kde.org/teams/automation/issues/-/issues</a>.</p>



<p>There&#8217;s now a wiki page explaining how distros can package Plasma for the best user experience, full of accumulated knowledge over time (me: Nate Graham. <a href="https://community.kde.org/Distributions/Packaging_Recommendations">Link</a>)</p>



<p>On distros using  <code>gdb</code> 12, the DrKonqi crash reporting wizard is now capable of dynamically symbolicating crash traces without debug symbols, which makes them actionable and reduces bug triaging work (Harald Sitter, Plasma 5.26.1. <a href="https://bugs.kde.org/show_bug.cgi?id=454063">Link</a>)</p>



<p>Added an autotest for the PNG metadata extractor (Kai Uwe Broulik, Frameworks 5.100. <a href="https://invent.kde.org/frameworks/kfilemetadata/-/merge_requests/71/diffs">Link</a>)</p>



<p>Added autotests for KWin&#8217;s DRM (Direct Rendering Manager) platform code (Xaver Hugl, Plasma 5.27. <a href="https://invent.kde.org/plasma/kwin/-/merge_requests/1271">Link</a>)</p>



<h2>Changes not in KDE that affect KDE</h2>



<p>RGB sub-pixel hinting for text is now enabled by default, which is good for users of KDE software since we respect the set of systemwide default settings rather than overriding it with our own value (Akira Tagoh, Fontconfig 2.14.1 <a href="https://gitlab.freedesktop.org/fontconfig/fontconfig/-/merge_requests/237">Link</a>)</p>



<h2 id="and-everything-else">&#8230;And everything else</h2>



<p>This blog only covers the tip of the iceberg! If you&#8217;re hungry for more, check out <a href="https://planet.kde.org" rel="nofollow">https://planet.kde.org</a>, where you can find more news from other KDE contributors.</p>



<h2 id="how-you-can-help">How You Can Help</h2>



<p>If you’re a developer, check out our <a href="https://pointieststick.com/2022/01/18/the-15-minute-bug-initiative/">15-Minute Bug Initiative</a>. Working on these issues makes a big difference quickly! Otherwise, have a look at <a href="https://community.kde.org/Get_Involved">https://community.kde.org/Get_Involved</a> to discover ways to be part of a project that really matters. Each contributor makes a huge difference in KDE; you are not a number or a cog in a machine! You don&#8217;t have to already be a programmer, either. I wasn&#8217;t when I got started. Try it, you’ll like it! We don’t bite!</p>



<p>Finally, consider <a href="https://www.kde.org/community/donations/index.php">making a tax-deductible donation</a> to the <a href="https://ev.kde.org/">KDE e.V. foundation</a>.</p>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-13323" class="share-twitter sd-button share-icon" href="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/?share=twitter" target="_blank" title="Click to share on Twitter" ><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-13323" class="share-facebook sd-button share-icon" href="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/?share=facebook" target="_blank" title="Click to share on Facebook" ><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-140354881-13323-635391f26c086' data-src='//widgets.wp.com/likes/index.html?ver=20220105#blog_id=140354881&amp;post_id=13323&amp;origin=pointieststick.wordpress.com&amp;obj_id=140354881-13323-635391f26c086&amp;domain=pointieststick.com' data-name='like-post-frame-140354881-13323-635391f26c086' data-title='Like or Reblog'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>	</div><!-- .entry-content -->

	<div class="entry-footer">
			</div><!-- .entry-footer -->

	<div class="entry-author-wrapper">
			<div class="entry-author author-avatar-show">
				<div class="author-avatar">
			<img alt='' src='https://2.gravatar.com/avatar/2c6c3c992e1122273dc3d92970d68781?s=80&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-80' height='80' width='80' />		</div><!-- .author-avatar -->
		
		<div class="author-heading">
			<h2 class="author-title">Published by <span class="author-name">Nate</span></h2>
		</div><!-- .author-heading -->

		<p class="author-bio">
						<a class="author-link" href="https://pointieststick.com/author/pointieststick/" rel="author">
				View all posts by Nate			</a>
		</p><!-- .author-bio -->
	</div><!-- .entry-auhtor -->
		<div class="site-posted-on">
			<strong>Published</strong>
			<time class="entry-date published updated" datetime="2022-10-21T22:42:09-06:00">October 21, 2022</time>		</div><!-- .site-posted-on -->
	</div>
</article><!-- #post-## -->

			
	<nav class="navigation post-navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://pointieststick.com/2022/10/21/interview-on-the-sudo-show/" rel="prev"><span class="meta-nav screen-reader-text">Previous Post</span> Interview on the Sudo&nbsp;Show</a></div></div>
	</nav>
			
<div id="comments" class="comments-area">

	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/10/21/this-week-in-kde-ui-improvements-abound-2/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://pointieststick.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="22104d33ee" /><input type="hidden" name="_wp_http_referer" value="/2022/10/21/this-week-in-kde-ui-improvements-abound-2/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">
	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" class="nascar-signin-link"
				 title="Login via Guest" 				>
									</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" class="nascar-signin-link"
				 title="Login via WordPress.com" 				>
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" class="nascar-signin-link"
				 title="Login via Twitter" 				>
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" class="nascar-signin-link"
				 title="Login via Facebook" 				>
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg>				</a>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://s0.wp.com/i/mu.gif" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
			
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://s0.wp.com/i/mu.gif" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
						<p class="comment-form-posting-as pa-wordpress">
			<strong></strong>
			You are commenting using your WordPress.com account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://s0.wp.com/i/mu.gif" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
						<p class="comment-form-posting-as pa-twitter">
			<strong></strong>
			You are commenting using your Twitter account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
						<p class="comment-form-posting-as pa-facebook">
			<strong></strong>
			You are commenting using your Facebook account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function () {

	function hide( sel ) {
		var el = document.querySelector( sel );
		if ( el ) {
			el.style.setProperty( 'display', 'none' );
		}
	}

	function show( sel ) {
		var el = document.querySelector( sel );
		if ( el ) {
			el.style.removeProperty( 'display' );
		}
	}

	var input = document.createElement( 'input' );
	var comment = document.querySelector( '#comment' );

	if ( input && comment && 'placeholder' in input ) {
		var label = document.querySelector( '.comment-textarea label' );
		if ( label ) {
			var text = label.textContent;
			label.parentNode.removeChild( label );
			comment.setAttribute( 'placeholder', text );
		}
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	hide( '#comment-form-identity' );
	hide( '#comment-form-subscribe' );
	hide( '#commentform .form-submit' );

	if ( comment ) {
		comment.style.height = '10px';

		var handler = function () {
			comment.style.height = HighlanderComments.initialHeight + 'px';
			show( '#comment-form-identity' );
			show( '#comment-form-subscribe' );
			show( '#commentform .form-submit' );
			HighlanderComments.resizeCallback();

			comment.removeEventListener( 'focus', handler );
		};

		comment.addEventListener( 'focus', handler );
	}
}

if ( document.readyState !== 'loading' ) {
	highlander_expando_javascript();
} else {
	document.addEventListener( 'DOMContentLoaded', highlander_expando_javascript );
}

</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit button" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='13323' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="af5c12cebe" /></p>
<input type="hidden" name="genseq" value="1666421234" />
<p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="146"/><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
	<div style="clear: both"></div>
</div><!-- #comments -->

		
		</main><!-- #main -->
	</div><!-- #primary -->

<div id="secondary" class="widget-area" role="complementary">
	<aside id="search-3" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://pointieststick.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside><aside id="follow_button_widget-3" class="widget widget_follow_button_widget">
		<a class="wordpress-follow-button" href="https://pointieststick.com" data-blog="140354881" data-lang="en" data-show-follower-count="true">Follow Adventures in Linux and KDE on WordPress.com</a>
		<script type="text/javascript">(function(d){var f = d.getElementsByTagName('SCRIPT')[0], p = d.createElement('SCRIPT');p.type = 'text/javascript';p.async = true;p.src = '//widgets.wp.com/platform.js';f.parentNode.insertBefore(p,f);}(document));</script>

		</aside><aside id="blog_subscription-3" class="widget widget_blog_subscription jetpack_subscription_widget"><h1 class="widget-title"><label for="subscribe-field">Follow via Email</label></h1>

			<div class="wp-block-jetpack-subscriptions__container">
			<form
				action="https://subscribe.wordpress.com"
				method="post"
				accept-charset="utf-8"
				id="subscribe-blog"
			>
				<p>Enter your email address to follow this blog and receive notifications of new posts by email.</p>
				<p id="subscribe-email">
					<label
						id="subscribe-field-label"
						for="subscribe-field"
						class="screen-reader-text"
					>
						Email Address:					</label>

					<input
							type="email"
							name="email"
							
							style="width: 95%; padding: 1px 10px"
							placeholder="Email Address"
							value=""
							id="subscribe-field"
						/>				</p>

				<p id="subscribe-submit"
									>
					<input type="hidden" name="action" value="subscribe"/>
					<input type="hidden" name="blog_id" value="140354881"/>
					<input type="hidden" name="source" value="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/"/>
					<input type="hidden" name="sub-type" value="widget"/>
					<input type="hidden" name="redirect_fragment" value="subscribe-blog"/>
					<input type="hidden" id="_wpnonce" name="_wpnonce" value="f8cbd6b0f5" />					<button type="submit"
													class="wp-block-button__link"
																	>
						Follow					</button>
				</p>
			</form>
							<div class="wp-block-jetpack-subscriptions__subscount">
					Join 721 other followers				</div>
						</div>
			
</aside><aside id="rss_links-3" class="widget widget_rss_links"><h1 class="widget-title">Follow via RSS</h1><ul><li><a href="https://pointieststick.com/feed/" title="Subscribe to Posts">RSS - Posts</a></li></ul>
</aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><h1 class="widget-title">Tip jar</h1><div class="textwidget custom-html-widget"><strong>LiberaPay:</strong><br /><a href="https://liberapay.com/ngraham/donate"><img alt="Donate using Liberapay" src="https://liberapay.com/assets/widgets/donate.svg"></a>
<br />
<strong>PayPal:</strong><br /><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&amp;hosted_button_id=Y279422B3LMRE"><img src="https://www.paypalobjects.com/en_US/i/btn/btn_donate_LG.gif" alt="donate with PayPal" /></a>
</div></aside><aside id="top-posts-3" class="widget widget_top-posts"><h1 class="widget-title">Popular posts</h1><ul class='widgets-list-layout no-grav'>
<li><a href="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/" title="This week in KDE: UI improvements abound" class="bump-view" data-bump-view="tp" aria-current="page"><img width="40" height="40" src="https://pointieststick.files.wordpress.com/2022/10/image-9.png?resize=40%2C40" alt="This week in KDE: UI improvements abound" data-pin-nopin="true" class="widgets-list-layout-blavatar" /></a><div class="widgets-list-layout-links">
								<a href="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/" title="This week in KDE: UI improvements abound" class="bump-view" data-bump-view="tp" aria-current="page">This week in KDE: UI improvements abound</a>
							</div>
							</li><li><a href="https://pointieststick.com/2022/10/21/interview-on-the-sudo-show/" title="Interview on the Sudo Show" class="bump-view" data-bump-view="tp"><img width="40" height="40" src="https://2.gravatar.com/avatar/2c6c3c992e1122273dc3d92970d68781?s=40&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G" alt="Interview on the Sudo Show" data-pin-nopin="true" class="widgets-list-layout-blavatar" /></a><div class="widgets-list-layout-links">
								<a href="https://pointieststick.com/2022/10/21/interview-on-the-sudo-show/" title="Interview on the Sudo Show" class="bump-view" data-bump-view="tp">Interview on the Sudo Show</a>
							</div>
							</li><li><a href="https://pointieststick.com/2022/10/17/on-hiring-and-fundraising-to-make-it-more-biggerer/" title="On hiring, and fundraising to make it more biggerer" class="bump-view" data-bump-view="tp"><img width="40" height="40" src="https://pointieststick.files.wordpress.com/2022/10/board.jpg?resize=40%2C40" alt="On hiring, and fundraising to make it more biggerer" data-pin-nopin="true" class="widgets-list-layout-blavatar" /></a><div class="widgets-list-layout-links">
								<a href="https://pointieststick.com/2022/10/17/on-hiring-and-fundraising-to-make-it-more-biggerer/" title="On hiring, and fundraising to make it more biggerer" class="bump-view" data-bump-view="tp">On hiring, and fundraising to make it more biggerer</a>
							</div>
							</li><li><a href="https://pointieststick.com/2022/10/14/this-week-in-kde-qa-pays-off/" title="This week in KDE: QA pays off" class="bump-view" data-bump-view="tp"><img width="40" height="40" src="https://pointieststick.files.wordpress.com/2022/10/image-3.png?resize=40%2C40" alt="This week in KDE: QA pays off" data-pin-nopin="true" class="widgets-list-layout-blavatar" /></a><div class="widgets-list-layout-links">
								<a href="https://pointieststick.com/2022/10/14/this-week-in-kde-qa-pays-off/" title="This week in KDE: QA pays off" class="bump-view" data-bump-view="tp">This week in KDE: QA pays off</a>
							</div>
							</li><li><a href="https://pointieststick.com/2022/06/17/this-week-in-kde-non-blurry-xwayland-apps/" title="This week in KDE: non-blurry XWayland apps!" class="bump-view" data-bump-view="tp"><img width="40" height="40" src="https://pointieststick.files.wordpress.com/2022/06/okular.png?resize=40%2C40" alt="This week in KDE: non-blurry XWayland apps!" data-pin-nopin="true" class="widgets-list-layout-blavatar" /></a><div class="widgets-list-layout-links">
								<a href="https://pointieststick.com/2022/06/17/this-week-in-kde-non-blurry-xwayland-apps/" title="This week in KDE: non-blurry XWayland apps!" class="bump-view" data-bump-view="tp">This week in KDE: non-blurry XWayland apps!</a>
							</div>
							</li></ul>
</aside><aside id="categories-3" class="widget widget_categories"><h1 class="widget-title">Categories</h1>
			<ul>
					<li class="cat-item cat-item-756083481"><a href="https://pointieststick.com/category/automation-systematization/">Automation &amp; Systematization</a>
</li>
	<li class="cat-item cat-item-12233"><a href="https://pointieststick.com/category/discover/">Discover</a>
</li>
	<li class="cat-item cat-item-713592128"><a href="https://pointieststick.com/category/foss-culture/">FOSS culture</a>
</li>
	<li class="cat-item cat-item-21820597"><a href="https://pointieststick.com/category/high-dpi/">High DPI</a>
</li>
	<li class="cat-item cat-item-706412123"><a href="https://pointieststick.com/category/inside-kde/">Inside KDE</a>
</li>
	<li class="cat-item cat-item-155269"><a href="https://pointieststick.com/category/linux-hardware/">Linux Hardware</a>
</li>
	<li class="cat-item cat-item-606063834"><a href="https://pointieststick.com/category/new-contributor-friendliness/">New Contributor Friendliness</a>
</li>
	<li class="cat-item cat-item-4599"><a href="https://pointieststick.com/category/planning/">Planning</a>
</li>
	<li class="cat-item cat-item-59597606"><a href="https://pointieststick.com/category/plasma-mobile/">Plasma Mobile</a>
</li>
	<li class="cat-item cat-item-610232629"><a href="https://pointieststick.com/category/presentations-interviews/">Presentations &amp; Interviews</a>
</li>
	<li class="cat-item cat-item-251959841"><a href="https://pointieststick.com/category/the-kde-community/">The KDE Community</a>
</li>
	<li class="cat-item cat-item-686543024"><a href="https://pointieststick.com/category/this-week-in-kde/">This Week in KDE</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://pointieststick.com/category/uncategorized/">Uncategorized</a>
</li>
	<li class="cat-item cat-item-603605952"><a href="https://pointieststick.com/category/usability-productivity/">Usability &amp; Productivity</a>
</li>
	<li class="cat-item cat-item-86713"><a href="https://pointieststick.com/category/user-interface-design/">User Interface Design</a>
</li>
	<li class="cat-item cat-item-98497"><a href="https://pointieststick.com/category/world-domination/">World Domination</a>
</li>
			</ul>

			</aside><aside id="archives-3" class="widget widget_archive"><h1 class="widget-title">Archives</h1>		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://pointieststick.com/2022/10/'> October 2022 </option>
	<option value='https://pointieststick.com/2022/09/'> September 2022 </option>
	<option value='https://pointieststick.com/2022/08/'> August 2022 </option>
	<option value='https://pointieststick.com/2022/07/'> July 2022 </option>
	<option value='https://pointieststick.com/2022/06/'> June 2022 </option>
	<option value='https://pointieststick.com/2022/05/'> May 2022 </option>
	<option value='https://pointieststick.com/2022/04/'> April 2022 </option>
	<option value='https://pointieststick.com/2022/03/'> March 2022 </option>
	<option value='https://pointieststick.com/2022/02/'> February 2022 </option>
	<option value='https://pointieststick.com/2022/01/'> January 2022 </option>
	<option value='https://pointieststick.com/2021/12/'> December 2021 </option>
	<option value='https://pointieststick.com/2021/11/'> November 2021 </option>
	<option value='https://pointieststick.com/2021/10/'> October 2021 </option>
	<option value='https://pointieststick.com/2021/09/'> September 2021 </option>
	<option value='https://pointieststick.com/2021/08/'> August 2021 </option>
	<option value='https://pointieststick.com/2021/07/'> July 2021 </option>
	<option value='https://pointieststick.com/2021/06/'> June 2021 </option>
	<option value='https://pointieststick.com/2021/05/'> May 2021 </option>
	<option value='https://pointieststick.com/2021/04/'> April 2021 </option>
	<option value='https://pointieststick.com/2021/03/'> March 2021 </option>
	<option value='https://pointieststick.com/2021/02/'> February 2021 </option>
	<option value='https://pointieststick.com/2021/01/'> January 2021 </option>
	<option value='https://pointieststick.com/2020/12/'> December 2020 </option>
	<option value='https://pointieststick.com/2020/11/'> November 2020 </option>
	<option value='https://pointieststick.com/2020/10/'> October 2020 </option>
	<option value='https://pointieststick.com/2020/09/'> September 2020 </option>
	<option value='https://pointieststick.com/2020/08/'> August 2020 </option>
	<option value='https://pointieststick.com/2020/07/'> July 2020 </option>
	<option value='https://pointieststick.com/2020/06/'> June 2020 </option>
	<option value='https://pointieststick.com/2020/05/'> May 2020 </option>
	<option value='https://pointieststick.com/2020/04/'> April 2020 </option>
	<option value='https://pointieststick.com/2020/03/'> March 2020 </option>
	<option value='https://pointieststick.com/2020/02/'> February 2020 </option>
	<option value='https://pointieststick.com/2020/01/'> January 2020 </option>
	<option value='https://pointieststick.com/2019/12/'> December 2019 </option>
	<option value='https://pointieststick.com/2019/11/'> November 2019 </option>
	<option value='https://pointieststick.com/2019/10/'> October 2019 </option>
	<option value='https://pointieststick.com/2019/09/'> September 2019 </option>
	<option value='https://pointieststick.com/2019/08/'> August 2019 </option>
	<option value='https://pointieststick.com/2019/07/'> July 2019 </option>
	<option value='https://pointieststick.com/2019/06/'> June 2019 </option>
	<option value='https://pointieststick.com/2019/05/'> May 2019 </option>
	<option value='https://pointieststick.com/2019/04/'> April 2019 </option>
	<option value='https://pointieststick.com/2019/03/'> March 2019 </option>
	<option value='https://pointieststick.com/2019/02/'> February 2019 </option>
	<option value='https://pointieststick.com/2019/01/'> January 2019 </option>
	<option value='https://pointieststick.com/2018/12/'> December 2018 </option>
	<option value='https://pointieststick.com/2018/11/'> November 2018 </option>
	<option value='https://pointieststick.com/2018/10/'> October 2018 </option>
	<option value='https://pointieststick.com/2018/09/'> September 2018 </option>
	<option value='https://pointieststick.com/2018/08/'> August 2018 </option>
	<option value='https://pointieststick.com/2018/07/'> July 2018 </option>
	<option value='https://pointieststick.com/2018/06/'> June 2018 </option>
	<option value='https://pointieststick.com/2018/05/'> May 2018 </option>
	<option value='https://pointieststick.com/2018/04/'> April 2018 </option>
	<option value='https://pointieststick.com/2018/03/'> March 2018 </option>
	<option value='https://pointieststick.com/2018/02/'> February 2018 </option>
	<option value='https://pointieststick.com/2018/01/'> January 2018 </option>
	<option value='https://pointieststick.com/2017/12/'> December 2017 </option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-3" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</aside></div><!-- #secondary -->

		</div><!-- #content -->

		<footer id="colophon" class="site-footer" role="contentinfo">
						<div class="site-info">
				<a href="https://wordpress.com/?ref=footer_blog" rel="nofollow">Blog at WordPress.com.</a>
				
							</div><!-- .site-info -->
		</footer><!-- #colophon -->
	</div><!-- #content-wrapper -->
</div><!-- #page -->

<!--  -->
<script type="text/javascript">
	window._tkq = window._tkq || [];
	if ( Math.random() < 0.01 ) {
		window._tkq.push( [
			'recordEvent',
			'wpcom_wordads_noad',
			{"theme":"pub\/independent-publisher-2","blog_id":140354881,"post_id":13323,"reason_noadverts_plugin":1,"reason_upgrade":1,"reason_blog_null":1,"reason_post_null":1}
		] );
	}
</script><script src='//0.gravatar.com/js/gprofiles.js?ver=202242z' id='grofiles-cards-js'></script>
<script id='wpgroho-js-extra'>
var WPGroHo = {"my_hash":""};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1610363240h'></script>

	<script>
		// Initialize and attach hovercards to all gravatars
		( function() {
			function init() {
				if ( typeof Gravatar === 'undefined' ) {
					return;
				}

				if ( typeof Gravatar.init !== 'function' ) {
					return;
				}

				Gravatar.profile_cb = function ( hash, id ) {
					WPGroHo.syncProfileData( hash, id );
				};

				Gravatar.my_hash = WPGroHo.my_hash;
				Gravatar.init( 'body', '#wp-admin-bar-my-account' );
			}

			if ( document.readyState !== 'loading' ) {
				init();
			} else {
				document.addEventListener( 'DOMContentLoaded', init );
			}
		} )();
	</script>

		<div style="display:none">
	<div class="grofile-hash-map-2c6c3c992e1122273dc3d92970d68781">
	</div>
	</div>
<script id='highlander-comments-js-extra'>
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/pointieststick.wordpress.com\/public.api\/connect\/?action=request&domain=pointieststick.com","logoutURL":"https:\/\/pointieststick.wordpress.com\/wp-login.php?action=logout&_wpnonce=50fe6e590a","homeURL":"https:\/\/pointieststick.com\/","postID":"13323","gravDefault":"blank","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s0.wp.com/_static/??/wp-content/js/textarea-autosize.min.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1663141412j'></script>
	<div id="actionbar" style="display: none;"
			class="actnbr-pub-independent-publisher-2 actnbr-has-follow">
		<ul>
								<li class="actnbr-btn actnbr-hidden">
								<a class="actnbr-action actnbr-actn-follow " href="">
			<svg class="gridicon gridicons-reader-follow" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M23 16v2h-3v3h-2v-3h-3v-2h3v-3h2v3h3zM20 2v9h-4v3h-3v4H4c-1.1 0-2-.9-2-2V2h18zM8 13v-1H4v1h4zm3-3H4v1h7v-1zm0-2H4v1h7V8zm7-4H4v2h14V4z"/></g></svg><span>Follow</span>
		</a>
		<a class="actnbr-action actnbr-actn-following  no-display" href="">
			<svg class="gridicon gridicons-reader-following" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M23 13.482L15.508 21 12 17.4l1.412-1.388 2.106 2.188 6.094-6.094L23 13.482zm-7.455 1.862L20 10.89V2H2v14c0 1.1.9 2 2 2h4.538l4.913-4.832 2.095 2.176zM8 13H4v-1h4v1zm3-2H4v-1h7v1zm0-2H4V8h7v1zm7-3H4V4h14v2z"/></g></svg><span>Following</span>
		</a>
							<div class="actnbr-popover tip tip-top-left actnbr-notice" id="follow-bubble">
							<div class="tip-arrow"></div>
							<div class="tip-inner actnbr-follow-bubble">
															<ul>
											<li class="actnbr-sitename">
			<a href="https://pointieststick.com">
				<img alt='' src='https://s2.wp.com/i/logo/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' />				Adventures in Linux and KDE			</a>
		</li>
										<form method="post" action="https://subscribe.wordpress.com" accept-charset="utf-8" style="display: none;">
																						<div class="actnbr-follow-count">Join 721 other followers</div>
																					<div>
										<input type="email" name="email" placeholder="Enter your email address" class="actnbr-email-field" aria-label="Enter your email address" />
										</div>
										<input type="hidden" name="action" value="subscribe" />
										<input type="hidden" name="blog_id" value="140354881" />
										<input type="hidden" name="source" value="https://pointieststick.com/2022/10/21/this-week-in-kde-ui-improvements-abound-2/" />
										<input type="hidden" name="sub-type" value="actionbar-follow" />
										<input type="hidden" id="_wpnonce" name="_wpnonce" value="f8cbd6b0f5" />										<div class="actnbr-button-wrap">
											<button type="submit" value="Sign me up">
												Sign me up											</button>
										</div>
									</form>
									<li class="actnbr-login-nudge">
										<div>
											Already have a WordPress.com account? <a href="https://wordpress.com/log-in?redirect_to=https%3A%2F%2Fr-login.wordpress.com%2Fremote-login.php%3Faction%3Dlink%26back%3Dhttps%253A%252F%252Fpointieststick.com%252F2022%252F10%252F21%252Fthis-week-in-kde-ui-improvements-abound-2%252F">Log in now.</a>										</div>
									</li>
								</ul>
															</div>
						</div>
					</li>
							<li class="actnbr-ellipsis actnbr-hidden">
				<svg class="gridicon gridicons-ellipsis" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M7 12c0 1.104-.896 2-2 2s-2-.896-2-2 .896-2 2-2 2 .896 2 2zm12-2c-1.104 0-2 .896-2 2s.896 2 2 2 2-.896 2-2-.896-2-2-2zm-7 0c-1.104 0-2 .896-2 2s.896 2 2 2 2-.896 2-2-.896-2-2-2z"/></g></svg>				<div class="actnbr-popover tip tip-top-left actnbr-more">
					<div class="tip-arrow"></div>
					<div class="tip-inner">
						<ul>
									<li class="actnbr-sitename">
			<a href="https://pointieststick.com">
				<img alt='' src='https://s2.wp.com/i/logo/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' />				Adventures in Linux and KDE			</a>
		</li>
								<li class="actnbr-folded-customize">
								<a href="https://pointieststick.wordpress.com/wp-admin/customize.php?url=https%3A%2F%2Fpointieststick.wordpress.com%2F2022%2F10%2F21%2Fthis-week-in-kde-ui-improvements-abound-2%2F">
									<svg class="gridicon gridicons-customize" height="20" width="20" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M2 6c0-1.505.78-3.08 2-4 0 .845.69 2 2 2 1.657 0 3 1.343 3 3 0 .386-.08.752-.212 1.09.74.594 1.476 1.19 2.19 1.81L8.9 11.98c-.62-.716-1.214-1.454-1.807-2.192C6.753 9.92 6.387 10 6 10c-2.21 0-4-1.79-4-4zm12.152 6.848l1.34-1.34c.607.304 1.283.492 2.008.492 2.485 0 4.5-2.015 4.5-4.5 0-.725-.188-1.4-.493-2.007L18 9l-2-2 3.507-3.507C18.9 3.188 18.225 3 17.5 3 15.015 3 13 5.015 13 7.5c0 .725.188 1.4.493 2.007L3 20l2 2 6.848-6.848c1.885 1.928 3.874 3.753 5.977 5.45l1.425 1.148 1.5-1.5-1.15-1.425c-1.695-2.103-3.52-4.092-5.448-5.977z"/></g></svg>									<span>Customize</span>
								</a>
							</li>
																<li class="actnbr-folded-follow">
												<a class="actnbr-action actnbr-actn-follow " href="">
			<svg class="gridicon gridicons-reader-follow" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M23 16v2h-3v3h-2v-3h-3v-2h3v-3h2v3h3zM20 2v9h-4v3h-3v4H4c-1.1 0-2-.9-2-2V2h18zM8 13v-1H4v1h4zm3-3H4v1h7v-1zm0-2H4v1h7V8zm7-4H4v2h14V4z"/></g></svg><span>Follow</span>
		</a>
		<a class="actnbr-action actnbr-actn-following  no-display" href="">
			<svg class="gridicon gridicons-reader-following" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M23 13.482L15.508 21 12 17.4l1.412-1.388 2.106 2.188 6.094-6.094L23 13.482zm-7.455 1.862L20 10.89V2H2v14c0 1.1.9 2 2 2h4.538l4.913-4.832 2.095 2.176zM8 13H4v-1h4v1zm3-2H4v-1h7v1zm0-2H4V8h7v1zm7-3H4V4h14v2z"/></g></svg><span>Following</span>
		</a>
										</li>
																	<li class="actnbr-signup"><a href="https://wordpress.com/start/">Sign up</a></li>
									<li class="actnbr-login"><a href="https://wordpress.com/log-in?redirect_to=https%3A%2F%2Fr-login.wordpress.com%2Fremote-login.php%3Faction%3Dlink%26back%3Dhttps%253A%252F%252Fpointieststick.com%252F2022%252F10%252F21%252Fthis-week-in-kde-ui-improvements-abound-2%252F">Log in</a></li>
																	<li class="actnbr-shortlink"><a href="https://wp.me/p9uUIp-3sT">Copy shortlink</a></li>
																	<li class="flb-report"><a href="http://en.wordpress.com/abuse/">Report this content</a></li>
																	<li class="actnbr-reader">
										<a href="https://wordpress.com/read/blogs/140354881/posts/13323">
											View post in Reader										</a>
									</li>
																	<li class="actnbr-subs">
										<a href="https://subscribe.wordpress.com/">Manage subscriptions</a>
									</li>
																		<li class="actnbr-fold"><a href="">Collapse this bar</a></li>
															</ul>
					</div>
				</div>
			</li>
		</ul>
	</div>
	
<script>
window.addEventListener( "load", function( event ) {
	var link = document.createElement( "link" );
	link.href = "https://s0.wp.com/wp-content/mu-plugins/actionbar/actionbar.css?v=20210915";
	link.type = "text/css";
	link.rel = "stylesheet";
	document.head.appendChild( link );

	var script = document.createElement( "script" );
	script.src = "https://s0.wp.com/wp-content/mu-plugins/actionbar/actionbar.js?v=20220329";
	script.defer = true;
	document.body.appendChild( script );
} );
</script>

			<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/pointieststick.com\/2022\/10\/21\/this-week-in-kde-ui-improvements-abound-2\/":13323};
	</script>
				<link crossorigin='anonymous' rel='stylesheet' id='all-css-0-3' href='https://s1.wp.com/_static/??-eJytzFEKAjEMBNALWUNRlv6IR5HdNGh206Y0rb2+Cu4BBP9mhuHBKA41N8oNUndF+p2zwUqtzLh9O5SqsWNjzXDjjLCI4mZgwpHsoQOeTOOIZgf41UvvJGSAc9VuJGCDC1W39ByF/mTu1334sNd08dN08iH4c1hfsgJkOA==?cssminify=yes' type='text/css' media='all' />
<script id='comment-like-js-extra'>
var comment_like_text = {"loading":"Loading...","swipeUrl":"https:\/\/s2.wp.com\/wp-content\/mu-plugins\/comment-likes\/js\/lib\/swipe.js?ver=20131008"};
</script>
<script id='coblocks-lightbox-js-extra'>
var coblocksLigthboxData = {"closeLabel":"Close Gallery","leftLabel":"Previous","rightLabel":"Next"};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/_static/??-eJydUNtOwzAM/SHSqBuq+oL4ljRxW7e5YSfd9vcYimBMsIe9RIl9bjn6lJVNsUAsemHtYEML+dws/KSvVqGq7OuEkbXHFVi/Vagwm+g80B2wTSHISO2k5WZwS/xhDT7ZlfWhafumVYwhe1AEW3PUDrnsSjtIpKa5DOncBIy3imWGIMa5DhqjgwxyiLu8PfIMpA4fUtFsOJmC6UE+r5glRlzVmGxlNeJ3gRitr+733wmyvzyYVvQ0W8Jc1CmL4J3ujRMLNRjSwXABkpsqZKSyv8J91rqJYyJNMEEEMiWRohoLBriO+x9NVjn5y4jef8Ffw0vbdc9933btcXkH9QfmWw=='></script>
<script crossorigin='anonymous' src='https://s0.wp.com/wp-includes/js/dist/vendor/lodash.min.js?m=1653325678h&#038;ver=4.17.19' id='lodash-js'></script>
<script id='lodash-js-after'>
window.lodash = _.noConflict();
</script>
<script id='jetpack-block-slideshow-js-extra'>
var Jetpack_Block_Assets_Base_Url = {"url":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/jetpack-plugin\/production\/_inc\/blocks\/"};
</script>
<script id='jetpack-carousel-js-extra'>
var jetpackSwiperLibraryPath = {"url":"https:\/\/s2.wp.com\/wp-content\/mu-plugins\/jetpack-plugin\/production\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/pointieststick.com\/wp-admin\/admin-ajax.php","nonce":"df02d1d545","display_exif":"1","display_comments":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/pointieststick.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fpointieststick.com%2F2022%2F10%2F21%2Fthis-week-in-kde-ui-improvements-abound-2%2F","blog_id":"140354881","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"stats_query_args":"blog=140354881&v=wpcom&tz=-6&user_id=0&subd=pointieststick","is_public":"1"};
</script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s0.wp.com/_static/??-eJylkUtOxDAMhi9E4paBiA3iKChNTOs2iaM4mcLtKcOUBRIg1J1/Pz6/YM3KcaqYKuTQRkoCY9vkgGXcIgXh3N/pk+5haBQ8TMyLACWPrzpS0rPcwH8Z1D+kgwjPURW0/u0gB8XZjGqqMfxMik3tsBlrtm65asiFfXOVOMEzJQdDYLedRwJ5lIlXOBOuB3CXGZ0t3ATDV/bu+GNWu5BErOqku0/c7ngpl2T/S+3eQq3Zcfwmjy4kky3ord++92FSGq+bPMXH3hhz292bzszvwAH2IA=='></script>
<script type='text/javascript'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript'>
wp.galleryBlockV2Enabled = true
</script>
<script type='text/javascript'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>	<iframe src='https://widgets.wp.com/likes/master.html?ver=20220105#ver=20220105&amp;origin=https://pointieststick.com' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'>
		<div class="likes-text">
			<span>%d</span> bloggers like this:		</div>
		<ul class="wpl-avatars sd-like-gravatars"></ul>
	</div>

		<script src="//stats.wp.com/w.js?63" defer></script> <script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'140354881','blog_tz':'-6','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'140354881','v':'wpcom','tz':'-6','user_id':'0','post':'13323','subd':'pointieststick'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1mNzc2NTVTamdsd0xoLz9RQkM2K298TXY9bERQMXc2MjhEaVZfb2wwakRoSj0mUkp1THptM1NdbkV1WjZIcU9mVWQmPUIvMlN6Jk8wW3NYVEJ3dWZOWExuWD9CbmxqLENKeHZKRG9sOWtMPXxsPzZaPWE9UDdDckNaeEFMRTd6X01ITlUsWnlbaT9+ZDF4Y1MzK2QzTHdodT9TWmEyaEE9Wm9lbDRqeDcwQlF3UVtUZEpvemtjK2RKdVpvSFkmaXlpTG9UfFRTR0VoWzZiZVV4TiY0JjVjPXY3WXZJUDJTcWNiVlhkejJSNjJVV1hyYW1yM0w4LDliP0NyaXEvSW52bjVGcG4/cFdTQnRGemZKRk9PeWhQNEMwMXE5a09oLTdGQyYvR3NFWVg2aElsOXdBTFUlXWl+SkVZcCY4ZVAyTFRdLD1DWlJ+RFJRL2NUbC15WGs1VmNSczBpdHJ8cg=='}]);
_stq.push([ 'clickTrackerInit', '140354881', '13323' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:1px;width:1px;overflow:hidden;position:absolute;bottom:1px;" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>
